Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Different Spell damage between Player and NPC


Recommended Posts

I need a little help here with the damage formula. I wanted to make different damage dealt to player and NPC. like if to Player = 3k-5k damage the damage dealt to npc can be 30k-50k like most of the mmorpg.
```
' set the vital
Vital = Spell(SpellNum).Vital
If TempPlayer(index).targetType = 1 Then
Vital = Round((Vital * 0.6)) * Round((Player(index).Level * 1.14)) * (Round((Stats.Intelligence + (Stats.Willpower / 2))) / 1.5)
Else
Vital = Round((Vital * 6)) * Round((Player(index).Level * 11.4)) * (Round((Stats.Intelligence + (Stats.Willpower / 2))) / 1.5)
End If
```
Here's the code, i think it looks fine already. But it's always dealt the same damage like to NPC = 5K and to Player still 5K.
Link to post
Share on other sites
@'Irij':

> Did you change anything else within the sub? Or just the vitals?

just the vitals

@'Mohenjo:

> If you're using the client.exe and not the f5 thingy (debugger?) then did you compile it?

It's in server and uhh what you mean?
Link to post
Share on other sites
Did you check player attack npc or player attack player in mod combat?
Two ways i can think of is, go to player attack npc ( in Mod combat server side)and just set the vital to whatever it is *10
or you can go to player attack player and set the vital to whatever it normal is *.1
Link to post
Share on other sites
@'or3o':

> Did you check player attack npc or player attack player  in mod combat?
> Two ways i can think of is, go to player attack npc  ( in Mod combat server side)and just set the vital to whatever it is *10
> or you can go to player attack player and set the vital to whatever it normal is *.1

There is no combat formula on there :( can you TV me to check it?
Link to post
Share on other sites
Are you running the code through the debugger or are you compiling it into an executable? Also, you can set breaking points on the line of code to see if it's executing. If you want, PM with your server code and I'll see what I can do.
Link to post
Share on other sites
@'Irij':

> Are you running the code through the debugger or are you compiling it into an executable? Also, you can set breaking points on the line of code to see if it's executing. If you want, PM with your server code and I'll see what I can do.

Fixed and thanks for your help bro! :D Silly me to not check all the Spell formula ahaha

![](http://i.imgur.com/YirqqOr.png)
To NPC

![](http://i.imgur.com/jar3KUz.png)
To Player
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...