Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[Bug Fix] Sound of Attack


Recommended Posts

**Sorry my english**

When a player attacks a target with your weapon, is not sent to the sound of the weapon chosen items in the editor.

**Open Server**

**1 -** In **modHandleData**, look for:

```
Sub HandleAttack
```

**2 -** After of:

```
CheckResource index, x, y
```

**3 -** Add:

```
If GetPlayerEquipment(index, Weapon) > 0 Then SendPlayerSound index, GetPlayerX(index), GetPlayerY(index), SoundEntity.seItem, GetPlayerEquipment(index, Weapon)
```

**Credits:**

Valentine
Link to post
Share on other sites
Wow you always finding nice bug fixes ![:P](http://www.touchofdeathforums.com/community/public/style_emoticons/<#EMO_DIR#>/tongue.png) keep it up !

By the way :

Do you know how to fix this bug? ^^

http://www.touchofdeathforums.com/community/index.php?/topic/129603-eadvanced-damage-bug/
Link to post
Share on other sites
EA have this bugfix too, but different method if fixing it ![:P](http://www.touchofdeathforums.com/community/public/style_emoticons/<#EMO_DIR#>/tongue.png), and clark i will try to look at it and fix bugfix ![:P](http://www.touchofdeathforums.com/community/public/style_emoticons/<#EMO_DIR#>/tongue.png)
Link to post
Share on other sites
> Wow you always finding nice bug fixes ![:P](http://www.touchofdeathforums.com/community/public/style_emoticons/<#EMO_DIR#>/tongue.png) keep it up !
>
> By the way :
>
> Do you know how to fix this bug? ^^
>
> [http://www.touchofde…ced-damage-bug/](http://www.touchofdeathforums.com/community/index.php?/topic/129603-eadvanced-damage-bug/)

Sorry, but only fix bugs of official versions of eclipse origins.
Link to post
Share on other sites
Yea I thought this was a bug too… Then after I fixed it awhile back i noticed that the sound plays when equipping a weapon or taking it off so I thought it was on purpose... Anyways u can also use sendmapsound if u want the whole map to here it.. I did it just for guns
Link to post
Share on other sites
> EA have this bugfix too, but different method if fixing it ![:P](http://www.touchofdeathforums.com/community/public/style_emoticons/<#EMO_DIR#>/tongue.png), and clark i will try to look at it and fix bugfix ![:P](http://www.touchofdeathforums.com/community/public/style_emoticons/<#EMO_DIR#>/tongue.png)

Yea urs makes it slower.

anyways nice find, Valentine
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...